Saturday, February 16, 2013

The joys of Exchange 2010 Service Pack 3 installation

Having just completed this process on a few of several servers.  Some news from the frontline…
  1. If you have Backup Exec in the mix, then stop the service before you start installing SP3 on any of your boxes.
  2. You may want (or need) to do the schema update to Active Directory before you start.  Either way, it’d be a good idea to ensure the upgrade is done and replicated before proceeding too far down the install
  3. You may get a warning about obtaining a Hotfix from during preparation on servers with a MBX role – grab it now, and have a look.  But it only applies to improved Failover Cluster performance in stretched DAG’s across datacentres.  So you may well not need it.
  1. You may wish to stop your exchange services before running setup.exe, I have seen it fail to wait long enough to stop services properly during the upgrade.  The SP3 install actually disables them before stopping (if you run services.msc you can see it happening).
  2. Lastly, when the setup is close to finishing and attacking the server roles, make sure Microsoft Exchange Active Directory Topology service is running, if not then the AD communication will fail and you will have a big red cross on your screen, that may have an impact on your cardiac health!  This can be monitored for and the services started by hand when the installation moves onto “Restoring services”.  So far I have seen this issue on MBX servers.  I decided to do it for all servers irrespective as the upgrade rolled out
Web pages that may help you:
So, onto further servers!
PS1: Oh, yes, you really mustn’t ignore a good backup as a really good idea – especially for those cardiac moments!
PS2: version changes in the management console (at the site on which I’m working) moved from 14.2 (Build 247.5) to 14.3 (Build 123.4)

No comments: